How to setup NordVPN or OpenVPN on an Amazon Fire TV Stick


#61

There’s probably a way you could just use your PC, for instance someone above said you could FTP into your Firestick, if that’s possible you could probably load the VPN software onto your Firestick that way. I had to use my android phone to load OpenVPN on to mine.


#62

Hello, I got the VPN set up and working I think–says it’s connected. But I only see my IP address when I check the network on my Firestick. Is there something else I need to do? Thanks for all the posts.


#63

Thanks CGlov, if you read through the thread I think someone else had the same problem, but when they’d test it, it showed the NordVPN IP even though the firestick was still showing their real IP.


#64

ok I’m probably really dense, i got everything installed just like you said. Everything is there…BUT… when I open it I have no way to move to “i already have an account” to log in. I tried converting to mouse mode, doesn’t work there…BTW…I am talking about on fire stick. I just want to open my Nordvpn and run it PLEASE help if you can. thanks. if you have an easy answer please also email to again thank youk


#65

Hi Gabby, not sure how to solve your problem of moving it to you the you already have an account option, no problems with this when I did it.

To open up OpenVPN though you can go to Settings - Apps - Manage Installed Applications I believe it is…

I removed your email address from your post otherwise you’d probably end up with a ton of spam.


#66

thanks I didn’t think of that. i have the nordvpn app right on the screen just no whete will it let me do anything but create a new account and I’m not paying for it again. thanjs for your help though


#67

I use the OpenVPN for Android app on mine, check out the instructions at the beginning of this post. I didn’t have any luck using the NordVPN app but you can use your Nord account with the OpenVPN app…


#68

The NordVPN android app does not work on Firestick at this time. You need to access NordVPN through the OpenVPN App that you sent to your firestick with Apps2Fire.


#69

thanks to all, I think I found the directions to do the load through opn vpn and it looks like u log on tothe Nordvpn from there. I will try tomorrow when my hubby is at work away from the tv!:stuck_out_tongue_winking_eye: Have a nice evening, I’ll let you know how I make out.


#70

ok still no good. could u possibly send me a step by step from begining to end. I just uninstalled all on my firestick. I have old android phone with 2fire on it and Openvpn…do I need openvpn connect?


#71

Same crap, will kinda on one firestick it works or the last time i checked was working , ip changed so that was cool.

But on my second attempt on my other firestick it says connected and all that good stuff but when i check my ip address it is still the same no change…

I installed it the same way i did on the first one that is working.

First i installed OpenVpn Connect on to my phone
Then I installed Apk Share, i opened Apk share then backed up OpenVpn Connect.
It saved the Apk file of OpenVpn then i uploaded that to google drive, from there i shared the link… It is a long URL so i shank it with tinyurl.com.

From there i went to my firestick , installed Es File Explorer
Then i typed the tinyurl adress of the APK i uploaded to google drive in favorites to add it, then downloaded and installed it, then i did the same for the nordvpn config files the .OPVN i used "open with Other"scrooled down to openvpn … It loaded ect…

But for some reason it only changed the ip on my first firestick it dose have the alexa remote and the other one doesn’t, but the only difference is the remote the remote works on both but one is about a year newer then the other …

So yeah… Guess it kinda works…
Try these then you won’t have to install anything on your phone

OpenVpn connect-as of August 2017 “http://tinyurl.com/yd5brom9

NordVpn config zip… Open with ES File Explorer pick one and “open with other”.
https://nordvpn.com/api/files/zip


#72

Just a heads up to the board, Nord deletes old servers periodically so make sure you are actually connecting. You may have to sideload a new config file if you are not connecting.


#73

I used dropbox to move the config file from my PC to the ES Explorer in firestick. in ES Explorer, go to Cloud, and select droppox. Sign in and copy the file from there to Local/Downloads. Then it’s available for you to connect to via OpenVPN


#74

I’ve tried a few different configurations and I’m not able to connect. I get a no process message. Any ideas?


#75

I googled the “no process” error message and couldn’t find anything on it, having never experienced this I have no idea but maybe someone else will.

Also is the No Process error coming from the Firestick or could it possibly be coming from your TV itself, is there something like a serial # for the error message?


#76

There is no error code. It’s from the app. I will try to upload a picture. Also, I am using this on a fire tv, not a fire stick. Not sure if that matters.


#77

So today I got billed by Nord for another year’s service even though I had a few years worth of credits from the OP I made here… so I go login to their site and it has been revamped and surprise my credits were nowhere to be found… what a ripoff… this will be my last year with NordVPN…


#78

Wot ain’t a ripoff these days


#79

I emailed them, will post here if they make it right or not… You know in my experience porn companies are a lot more honest, give you a way better cut and are more likely to pay up than these mainstream companies.


#80

I am using OpenVPN with NordVPN servers on cell phones and a tablet with the Android OS, and on 3 PCs (Windows 10). I am trying to set up OpenVPN on my Fire TV Cube. I have already installed the OpenVPN app as well as about a dozen OpenVPN config files which I downloaded from the NordVPN web site (www.nordvpn.com/ovpn). However, when I select an OVPN config file and then chose Import OpenVPN configuration, I get an error message that says "Importing the config yielded an error, cannot save it."
The web site I downloaded the config files from does that say that they will work only in Windows, for example. I tried both UDP and TCP files.
I